АВТ
Язык:

Дистанционный практикум по программированию

Задачи Online статус Турниры
Учебники Справка СДО
 
Здравствуйте, Гость! Войдите с паролем или зарегистрируйтесь.

1801. Черепашка

Ограничение времени: 1 сек.
Ограничение памяти:262144 КБайт
Баллы:100
Статистика Послать на проверку Задачу добавил debug

Исполнитель ЧЕРЕПАШКА перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существуют следующие команды:

Вперёд n, где n – целое число, вызывающая передвижение ЧЕРЕПАШКИ на n шагов в направлении движения;

Вправо m, где m – целое число, вызывающая изменение направления движения на m градусов по часовой стрелке.

Влево m, где m – целое число, вызывающая изменение направления движения на m градусов против часовой стрелке.

Запись Повтори k [Команда 1 Команда 2] означает, что последовательность команд в скобках повторится k раз.

Вам необходимо ответить на следующие вопросы:

1. Сколько вершин у фигуры, которая появится на экране после выполнения команд Повтори 4 [Вперед 30 Вправо 90]

2. Какое значение команды Вперёд надо задать, чтобы длина стороны фигуры увеличились в 2 раза?

3. Сколько таких фигур будет нарисовано после исполнения следующей программы?

Повтори 3 [Повтори 4 [Вперед 30 Вправо 90] Влево 90]

4. Сколько отрезков черепашка нарисует дважды (командой Вперед) при выполнении программы из предыдущего пункта?

5.Какое значение команды Влево надо задать вместо 90, чтобы после выполнения алгоритма из пункта 3 получить фигуру, изображенную на рисунке (ответ должен быть в интервале от 0 до 180).

Формат ответа

Решением данной задачи должны быть ровно пять чисел – ответы на пункты 1 – 5. Числа отделяйте друг от друга пробелом или переводом строки. Если вы не знаете все правильные ответы, то вместо недостающих напишите число 0.

Пример, как может выглядеть возможный ответ (примечание: этот ответ неправильный):

7 8 9 10 11

Система оценки

За каждое верное значение из пяти начисляется 20 баллов.


Статистика Послать на проверку Обсуждение задачи Автор/источник:
Задачи с соревнований / Школьные олимпиады Вологодской области / Муниципальный этап 2017-18 / Классы 7-8 /
1800. 1 - Числовая последовательность 1801. 1802. 3 - Игра 1803. 4 - Отношение углов 1804. 5 - Экономный садовод
 
время генерации 0.079 сек.
© Copyright ВоГУ, АВТ, Носов Д.А., Андрианов И.А.